Заметка о [ErrorException] E_DEPRECATED — D7 и php 5.6

[ErrorException] E_DEPRECATED mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead (0) ………..

В 2018 году Инсталлятор продукта версии 17.5.7. требует минимальную версию PHP 5.6., отсюда и возникают данные проблемы, т.е. если ваш проект работает на php ниже 5.5., а вы обновили ядро bitrix до версии 17.5.7. потребуются небольшие манипуляции

Используемое в продукте расширение mysql объявлено устаревшим в PHP 5.5.0. Поэтому в новом ядре было сразу предусмотрено использование актуального расширения mysqli. Так как ниже версии ядра не умели работать  с mysqli, то необходимо обновить ядро от 14.5.2 версии.

Для того чтобы включить поддержку mysqli необходимо модифицировать 2 файла, dbconn.php и settings.php

Заходим на хостинг по пути: \bitrix\php_interface\dbconn.php. Добавляем строку в файл

Сохраняем. Теперь идем по пути: \bitrix\.settings.php. И изменяем строку в файле в секции ‘connections’ =>

На этом все!

 

Читать  Навигационная цепочка - bitrix breadcrumb

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *